MCC Island Webstore experiencing degraded performance

Server maintenance

Resolved
Under maintenance
Started 18 days ago Lasted about 4 hours

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    This incident has been resolved. We've opened up the network back to public. Sorry for the inconvenience!

  • Monitoring
    Monitoring

    We've found a solution to our issues and are working on getting the server back up. Expecting things to be ready to go within the next 15 minutes.

  • Identified
    Update

    We're still working hard to try and bring the server back online! Thank you all for your patience whilst we try and iron out some rather large backend issues with the network. We'll keep you all updated here if anything changes.

  • Identified
    Update

    We are still working hard to resolve this issue and will continue to update this status page if we have any further information. Once again we are sorry for the inconvenience. Hang tight!

  • Identified
    Update

    We've had to take down the network for a few minutes while an unexpected issue occurred as we were working on a hardware issue.

    We'll be back shortly!

  • Identified
    Identified

    Whilst attempting to restore the network we have encountered a larger issue that may take some time to rectify. We are sorry for the inconvenience and the network will likely be offline for a while longer whilst we work on a fix.