MCC Island Webstore experiencing degraded performance

Server maintenance

Completed
Scheduled for March 27, 2024 at 12:00 – 12:25

Affects

MCC Island Minecraft Server
Updates
  • Completed
    March 27, 2024 at 12:25
    Completed
    March 27, 2024 at 12:25

    Maintenance has completed and the server is now back online.

  • In progress
    March 27, 2024 at 12:00
    In progress
    March 27, 2024 at 12:00
    Maintenance is now in progress
  • Planned
    March 27, 2024 at 12:00
    Planned
    March 27, 2024 at 12:00

    We are planning to take the server down for a short period of time to do some routine maintenance.