MCC Island Webstore experiencing degraded performance

Server maintenance

Completed
Scheduled for February 28, 2024 at 10:30 – 12:18

Affects

MCC Island Minecraft Server
Updates
  • Completed
    February 28, 2024 at 12:18
    Completed
    February 28, 2024 at 12:18

    This is now complete.

  • Update
    February 28, 2024 at 11:31
    In progress
    February 28, 2024 at 11:31

    Finishing up the maintenance shortly, just performing a final few checks.

  • In progress
    February 28, 2024 at 10:30
    In progress
    February 28, 2024 at 10:30
    Maintenance is now in progress