MCC Island Webstore experiencing degraded performance

Server maintenance

Completed
Scheduled for February 13, 2024 at 11:30 – 12:49

Affects

MCC Island Minecraft Server
Updates
  • Completed
    February 13, 2024 at 12:49
    Completed
    February 13, 2024 at 12:49

    Maintenance is complete and the server is back up now.

  • In progress
    February 13, 2024 at 11:30
    In progress
    February 13, 2024 at 11:30
    Maintenance is now in progress
  • Planned
    February 13, 2024 at 11:30
    Planned
    February 13, 2024 at 11:30

    We are planning to take the server down to address some of the recent server instability issues and to perform some routine maintenance tasks.